unable to /oper

Matt Best matthew.best at gmail.com
Wed Dec 8 12:52:53 EST 2004

I'm running Hybrid 7.0.3-1 on Debian Sarge.  I cannot seem to get
/oper access to work no matter what I do.  In my ircd.conf I have the

operator {
        /* name: the name of the oper */
        name = "matt";

        /* user: the user at host required for this operator.  CIDR is not
         * supported.  multiple user="" lines are supported.
        user = "*@*";

        /* password: the password required to oper.  By default this will
         * need to be encrypted using '/usr/bin/mkpasswd'.
         * WARNING: Please do not mix up the 'mkpasswd' program from
         * /usr/sbin with this one. If you are root, typing 'mkpasswd'
         * will run that one instead and you will receive a strange error.
         * MD5 is supported. If you want to use it, use mkpasswd -Hmd5.
        password = "$1$Rqnnlht/$Su4sk8hQzRXzZKbFF9CMG.";

        /* class: the class the oper joins when they successfully /oper */
        class = "opers";

        global_kill = yes;
        remote = yes;
        kline = yes;
        unkline = yes;
        gline = yes;
        die = yes;
        rehash = yes;
        nick_changes = yes;
        admin = yes;

I have tried every user at host that I can imagine.  Is the user at host
setting supposed to match what is displayed when I run a /whois on
myself?  I finally decided to just try *@*, however I don't know if
its even valid.  I'm trying to /oper using the command "/oper password
<mypassword>", is this correct syntax?  It gives me the message "only
mere mortals may try blah blah.."

I'm thinking possibly my mkpasswd utility is fnorked.  I've tried
plain-text, mkpasswd with no switches and mkpasswd --hash=md5 and
nothing works.  Does anybody know what I'm doing wrong here?  Thanks.

Kind regards, 


More information about the hybrid mailing list