[hybrid] Clients can't connect (register) on Ubuntu 12.04LTS system

David Smith dfluff76+hybrid at gmail.com
Thu Jul 11 16:43:24 EDT 2013


I'm having a headache of a time building a PC to replace my previous server
box, which has been running ircd-hybrid for many years.

The new box is a 64bit machine, with Ubuntu 12.04LTS 64-bit server edition

I've installed ircd-hybrid, and moved my old config across, but when that
failed to work, I went back to basics, and used the provided ircd.conf,
with only the server IP and the "havent_read_conf" setting changed (i.e. no
server passwords or any other obvious gotchas).

The problem is that whenever any client connects, I get the following:
21:20 -!- Irssi: Connection to established
21:20 !hybrid7.debian.local *** Looking up your hostname...
21:20 !hybrid7.debian.local *** Checking Ident
21:20 !hybrid7.debian.local *** No Ident response

....but then *nothing* else.  I can leave it for many minutes, (5...
10...), after which the connection sometimes drops out, sometimes doesn't,
depending on the client.

I have tried through the address, and through the eth0 LAN
address.  I have tried clients on other machines.  There is no firewall in
the way (nothing in "iptables -L").

Don't be fooled by the "No Ident response" final line... I have tried
installing an ident server, so that it DID get an ident response, and it
halted at just the same point.

The version installed here is the stock from Ubuntu12.04LTS,
7.2.2.dfsg.2-6.3 but I have tried other versions from ealier/later Ubuntu
distros.  I think I've also tired an 8.x version (..I've tried so many
things, I've lost track..), and all of those that I have managed to
install/compile successfully have behaved the in the same way.  My original
attempt was a self-compiled .deb with SSL enabled, but, again, that did not
work, although the very same .deb did work on another 12.04LTS 64-bit
machine.  I've even formatted the box, and done a fresh OS install followed
by an apt-get install of hybrid-ircd,  and still get the same results!

I have only found a handful of posts describing this problem on Google, and
of those, one ended in the advice of "use another ircd", and the other
threads just went cold, or never got a first response.  I cannot use
another ircd, since I'm joining this to other hybrid-ircds on other boxes.

(eg http://ubuntuforums.org/showthread.php?t=1432177  and
http://bit.ly/18QqdHs  both sound like my problem, but with no solutions).

So.. have you guys come across anything like this?  Or, what can I do to
help diagnose the problem?

Many thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ircd-hybrid.org/pipermail/hybrid/attachments/20130711/844947e1/attachment.html>

More information about the hybrid mailing list